凌的博客

您现在的位置是:首页  > 学无止境 > PHP

PHP

php和apache配置 LoadModule php5_module D:/php/php5apache2.dll

2015-06-04PHP0
1.路径一定要是英文符号 网上的教程,的确先安装Apache,在安装php,不过php还是下绿色版的好,在修改httpd.conf文件时,大多数人都 是:LoadModule php5_module c:\\Program Files\\php\\php5apache2.dll,都是apac
1.路径一定要是英文符号

网上的教程,的确先安装Apache,在安装php,不过php还是下绿色版的好,在修改httpd.conf文件时,大多数人都
是:LoadModule php5_module c:\Program Files\php\php5apache2.dll,都是apache restart出错。改正方法在路
径上加上""(英文双引号),即LoadModule php5_module "c:\Program Files\php\php5apache2.dll"。

呵呵。不过类似php5apache2.dll配置文件要根据你所安装的apache的版本来决定哦。。

2.缺少DLL


在给apache配置php的过程中,如果php安装目录里没有php5apache2_2.dll,一般是下载的php版本不对。
php 5 官网上下载PHP分 v9版 和 v6 等好几个版本。

在php官方网站上左边有这样几段文字:

我需要选择哪种版本的PHP?

如果你在apaceh1或apache2上使用php,你需要使用vc6版本的php。

vc6又有如下两种版本:

vc6 x86 non thread safe   非线程安全
vc6 x86 thread safe          线程安全

以上两个版本中,non thread safe版的php在安装过程中,没有apache的选项,而thread safe版的安装过程中有apache 2.2.x module选项。

所以你可以选择更换另一种版本的PHP,可以下载的版本 php vc6 x86 thread safe 的版本试试。



apache httpd.conf 

LoadModule php5_module "D:/AServer/php-5.3.5-ts/php5apache2_2.dll" 
PHPIniDir "D:/AServer/php-5.3.5-ts" 
AddType application/x-httpd-php .php .html .htm 

如果本文对您有所帮助,请支持下本站哦!!!^_^

文章评论

0条评论